[Jack-Devel] JACK1: Promiscuous mode doesn't work

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Jack-Devel] JACK1: Promiscuous mode doesn't work

Alex Ivanov
Jack1 is run as following

export JACK_PROMISCUOUS_SERVER=
umask 0
jackd -dalsa

JACK_PROMISCUOUS_SERVER is exported in environment.
Now programs using jack don't show any errors, but there is no sound and jackd gives the following errors:

мар 24 17:25:41 nixos jackd[15035]: jackd 0.125.0
мар 24 17:25:41 nixos jackd[15035]: Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
мар 24 17:25:41 nixos jackd[15035]: jackd comes with ABSOLUTELY NO WARRANTY
мар 24 17:25:41 nixos jackd[15035]: This is free software, and you are welcome to redistribute it
мар 24 17:25:41 nixos jackd[15035]: under certain conditions; see the file COPYING for details
мар 24 17:25:41 nixos jackd[15035]: JACK compiled with System V SHM support.
мар 24 17:25:41 nixos jackd[15035]: loading driver ..
мар 24 17:25:41 nixos jackd[15035]: creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
мар 24 17:25:41 nixos jackd[15035]: configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
мар 24 17:25:41 nixos jackd[15035]: ALSA: final selected sample format for capture: 32bit integer little-endian
мар 24 17:25:41 nixos jackd[15035]: ALSA: use 2 periods for capture
мар 24 17:25:41 nixos jackd[15035]: ALSA: final selected sample format for playback: 32bit integer little-endian
мар 24 17:25:41 nixos jackd[15035]: ALSA: use 2 periods for playback
мар 24 17:26:23 nixos jackd[15035]: subgraph starting at ADLplug timed out (subgraph_wait_fd=9, status = 0, state = Triggered, pollret = 0 revents = 0x0)
мар 24 17:26:23 nixos jackd[15035]: pp: cannot clean up byte from graph wait fd - no data present
мар 24 17:26:23 nixos jackd[15035]: **** alsa_pcm: xrun of at least 42199.144 msecs
мар 24 17:26:23 nixos jackd[15035]: subgraph starting at ADLplug timed out (subgraph_wait_fd=9, status = 0, state = Triggered, pollret = 0 revents = 0x0)
мар 24 17:26:23 nixos jackd[15035]: pp: cannot clean up byte from graph wait fd - no data present
_______________________________________________
Jack-Devel mailing list
[hidden email]
http://lists.jackaudio.org/listinfo.cgi/jack-devel-jackaudio.org
Reply | Threaded
Open this post in threaded view
|

Re: JACK1: Promiscuous mode doesn't work

Thomas Brand
On Wed, March 27, 2019 18:01, Alex Ivanov wrote:
> Jack1 is run as following
>
>
> export JACK_PROMISCUOUS_SERVER= umask 0 jackd -dalsa
>
> JACK_PROMISCUOUS_SERVER is exported in environment.
> Now programs using jack don't show any errors, but there is no sound and
> jackd gives the following errors:
>

A quick question, does do the same with jack2?


_______________________________________________
Jack-Devel mailing list
[hidden email]
http://lists.jackaudio.org/listinfo.cgi/jack-devel-jackaudio.org
Reply | Threaded
Open this post in threaded view
|

Re: JACK1: Promiscuous mode doesn't work

Alex Ivanov
In reply to this post by Alex Ivanov
>On Wed, March 27, 2019 18:01, Alex Ivanov wrote:
>> Jack1 is run as following
>>
>>
>> export JACK_PROMISCUOUS_SERVER= umask 0 jackd -dalsa
>>
>> JACK_PROMISCUOUS_SERVER is exported in environment.
>> Now programs using jack don't show any errors, but there is no sound and
>> jackd gives the following errors:
>>
>
> A quick question, does do the same with jack2?

No. This feature works fine in Jack2. And it doesn't need umask hack either.
However, it told in Jack1 manual that it supports promiscuous mode, but it doesn't work for me for some reason :-(
_______________________________________________
Jack-Devel mailing list
[hidden email]
http://lists.jackaudio.org/listinfo.cgi/jack-devel-jackaudio.org