Missing symbols

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing symbols

Matt Savigear-9
Hi all,

I'm having trouble getting jackd or jackdmp to launch. For jackdmp:

15:43:33.453 JACK is starting...
15:43:33.453 /usr/bin/jackdmp -R -P80 -dalsa -r44100 -p256 -n3 -D
-Chw:2,2 -Phw:2,2 -i2 -o2
could not open driver .so '/usr/lib/jackmp/jack_alsa.so':
/usr/lib/jackmp/jack_alsa.so: undefined symbol: jack_midi_event_reserve
jackdmp: unknown driver 'alsa'
15:43:33.478 JACK was started with PID=4164.
15:43:33.479 JACK was stopped with exit status=1.

For jackd:
15:49:50.380 /usr/bin/jackd -R -P80 -dalsa -r44100 -p256 -n3 -D -Chw:2,2
-Phw:2,2 -i2 -o2
could not open driver .so '/usr/lib64/jack/jack_dummy.so':
/usr/lib64/jack/jack_dummy.so: undefined symbol: jack_info
could not open driver .so '/usr/lib64/jack/jack_alsa.so':
/usr/lib64/jack/jack_alsa.so: undefined symbol: jack_info
could not find any drivers in /usr/lib64/jack!
jackd: no drivers found; exiting
15:49:50.412 JACK was started with PID=30679.
15:49:50.412 JACK was stopped with exit status=1.
15:49:50.412 Post-shutdown script...

My system:
Gentoo x86_64 running the pro-audio overlay on an Intel quad-core Q6600
processor. I have recompiled alsa-plugins as well as jack and jackdmp in
various orders.

Can anyone suggest a fix for this? It's a new motherboard and I'm hoping
the change of hardware will fix teh crackling I've had on my us-122 for
months.

--
Cheers,

Matt.

"There is no point in further discussion. Discussion is for the wise and
the helpless, and I am neither." - Leela of the Sevateem



-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Stéphane Letz

Le 29 janv. 08 à 16:52, Matt Savigear a écrit :

> Hi all,
>
> I'm having trouble getting jackd or jackdmp to launch. For jackdmp:
>
> 15:43:33.453 JACK is starting...
> 15:43:33.453 /usr/bin/jackdmp -R -P80 -dalsa -r44100 -p256 -n3 -D
> -Chw:2,2 -Phw:2,2 -i2 -o2
> could not open driver .so '/usr/lib/jackmp/jack_alsa.so':
> /usr/lib/jackmp/jack_alsa.so: undefined symbol:  
> jack_midi_event_reserve
> jackdmp: unknown driver 'alsa'
> 15:43:33.478 JACK was started with PID=4164.
> 15:43:33.479 JACK was stopped with exit status=1.
>

Which version of jackdmp?

// could not open driver .so '/usr/lib/jackmp/jack_alsa.so':

On a 64 bits machine, you'll have to edit the "libdir" var to be  
"lib64" in jackdmp "stupid" /linux/Makefile...

Stephane
-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Pieter Palmers
In reply to this post by Matt Savigear-9
Matt Savigear wrote:

> Hi all,
>
> I'm having trouble getting jackd or jackdmp to launch. For jackdmp:
>
> 15:43:33.453 JACK is starting...
> 15:43:33.453 /usr/bin/jackdmp -R -P80 -dalsa -r44100 -p256 -n3 -D
> -Chw:2,2 -Phw:2,2 -i2 -o2
> could not open driver .so '/usr/lib/jackmp/jack_alsa.so':
> /usr/lib/jackmp/jack_alsa.so: undefined symbol: jack_midi_event_reserve
> jackdmp: unknown driver 'alsa'
> 15:43:33.478 JACK was started with PID=4164.
> 15:43:33.479 JACK was stopped with exit status=1.
>
> For jackd:
> 15:49:50.380 /usr/bin/jackd -R -P80 -dalsa -r44100 -p256 -n3 -D -Chw:2,2
> -Phw:2,2 -i2 -o2
> could not open driver .so '/usr/lib64/jack/jack_dummy.so':
> /usr/lib64/jack/jack_dummy.so: undefined symbol: jack_info
> could not open driver .so '/usr/lib64/jack/jack_alsa.so':
> /usr/lib64/jack/jack_alsa.so: undefined symbol: jack_info
> could not find any drivers in /usr/lib64/jack!
> jackd: no drivers found; exiting
> 15:49:50.412 JACK was started with PID=30679.
> 15:49:50.412 JACK was stopped with exit status=1.
> 15:49:50.412 Post-shutdown script...
>
> My system:
> Gentoo x86_64 running the pro-audio overlay on an Intel quad-core Q6600
> processor. I have recompiled alsa-plugins as well as jack and jackdmp in
> various orders.
Did you compile ALSA sequencer support into libalsa?

Other Gentoo users have reported similar issues where the cause was that
gentoo doesn't include alsa seq support by default.

Greets,

Pieter

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Matt Savigear-9
In reply to this post by Stéphane Letz
Thanks for the fast response!

Stéphane Letz wrote:
> Which version of jackdmp?

Ah, 0.69 at the moment.

> // could not open driver .so '/usr/lib/jackmp/jack_alsa.so':
>
> On a 64 bits machine, you'll have to edit the "libdir" var to be "lib64"
> in jackdmp "stupid" /linux/Makefile...

Oh yes, I didn't spot that. I have changed the makefile, however I get a
new error on compilation:

g++ -g  -fPIC -DJACKMP -DSOCKET_RPC_FIFO_SEMA -D__SMP__
-DADDON_DIR=\"/usr\" -DLIB_DIR=\"lib64\" -DJACK_LOCATION=\"/usr/bin\"
-I../common -I../common/jack -I../tests -I../example-clients -Ialsa
-Ifreebob -Ifirewire -I../linux -I.. -march=nocona -O2 -pipe
-fomit-frame-pointer   Jackdmp.o  -lpthread -lrt -lasound libjackdmp.so
-o jackdmp
libjackdmp.so: file not recognized: File format not recognized
collect2: ld returned 1 exit status


--
Cheers,

Matt.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Matt Savigear-9
In reply to this post by Pieter Palmers
Pieter Palmers wrote:

> Did you compile ALSA sequencer support into libalsa?
>
> Other Gentoo users have reported similar issues where the cause was that
> gentoo doesn't include alsa seq support by default.

It's compiled into my kernel (or, more specifically, as a module).

--
Cheers,

Matt.

Flight to Peru: £1000
Camping gear: £400
Native guide to take you into the mountains: £350
Radiation detector to find mysteriously radioactive old tomb: £150
Sledgehammer to break down stone door: £12.99
Awakening one of the Great Old Ones: priceless.

There are some things man was not meant to know. For everything else,
there's Mastercard.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Matt Savigear-9
In reply to this post by Matt Savigear-9
Stéphane Letz wrote:
> Hum...
>
> make clean && make ??

Well, a make clean, make and make install has given me an executable.
Which segfaults!

matt@cthulhu ~ $ /usr/bin/jackdmp -R -P80 -dalsa -r44100 -p256 -n3 -D
-Chw:2,2 -Phw:2,2 -i2 -o2
jackdmp 0.69
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2007 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
apparent rate = 44100
frames per period = 256
capture device hw:2,2
playback device hw:2,2
control device hw:2
Segmentation fault

I'm going to try downgrading to plain old jack 103 which was the last
version I had which worked.

--
Cheers,

Matt.

"There is no point in further discussion. Discussion is for the wise and
the helpless, and I am neither." - Leela of the Sevateem


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Stéphane Letz

Le 29 janv. 08 à 17:45, Matt Savigear a écrit :

> Stéphane Letz wrote:
>> Hum...
>> make clean && make ??
>
> Well, a make clean, make and make install has given me an  
> executable. Which segfaults!
>
> matt@cthulhu ~ $ /usr/bin/jackdmp -R -P80 -dalsa -r44100 -p256 -n3 -
> D -Chw:2,2 -Phw:2,2 -i2 -o2
> jackdmp 0.69
> Copyright 2001-2005 Paul Davis and others.
> Copyright 2004-2007 Grame.
> jackdmp comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
> apparent rate = 44100
> frames per period = 256
> capture device hw:2,2
> playback device hw:2,2
> control device hw:2
> Segmentation fault
>
> I'm going to try downgrading to plain old jack 103 which was the  
> last version I had which worked.
>
> --
> Cheers,
>
> Matt.
>
> "There is no point in further discussion. Discussion is for the wise  
> and the helpless, and I am neither." - Leela of the Sevateem
>

Well having a crash log or also starting the server in verbose mode  
with -v  and sending the log would help,....

/usr/bin/jackdmp -v -R -P80 -dalsa -r44100 -p256 -n3 -D -Chw:2,2 -Phw:
2,2 -i2 -o2

if you find some time for that.

Stephane
-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: Missing symbols

Matt Savigear-9
Stéphane Letz wrote:
> Well having a crash log or also starting the server in verbose mode with
> -v  and sending the log would help,....
>
> /usr/bin/jackdmp -v -R -P80 -dalsa -r44100 -p256 -n3 -D -Chw:2,2
> -Phw:2,2 -i2 -o2
>
> if you find some time for that.

Well, jack 0.103 seems to work fine and I'm finally running without
crackle against my USB card. I know I'm probably missing out on new
features and (of course) SMP support but I'm currently more interested
in having the working version.

Many thanks Stéphane for your help on this. If I decide to have another
crack at jackdmp I'll come back to the list with some more comprehensive
  data for you.

--
Cheers,

Matt.

"Stoning non conformists is part of science. Stoning conformists is also
part of science. Only those theories that can stand up to a merciless
barrage of stones deserve consideration. It is the Creationist habit of
throwing marshmallows that we find annoying." - Dr. Pepper

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel