autoconnect on OS X with old jack?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

autoconnect on OS X with old jack?

Jonatan Liljedahl
The Jack OSX framework is still 0.101.1... will there be a new release soon?

When I try to autoconnect to system:playback_X it doesn't work, any tips?

--
/Jonatan         [ http://kymatica.com ]

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: autoconnect on OS X with old jack?

Stéphane Letz

Le 19 mars 08 à 01:34, Jonatan Liljedahl a écrit :

> The Jack OSX framework is still 0.101.1... will there be a new  
> release soon?
>
> When I try to autoconnect to system:playback_X it doesn't work, any  
> tips?
>
> --
> /Jonatan         [ http://kymatica.com ]
>

The situation on OSX is the following : starting with JackOSX 0.75  
package, jackdmp is used installed of old jackd. Jackdmp is compiled  
as 2 frameworks, but the libjack.so and libjack.so.0 links are done so  
that applications coming from Linux can still be compiled and linked  
without complaining. Moreover a jack.pc file to be used by pkg-config  
is installed in /usr/local/lib. Because jackdmp (0.69 and over) and  
jackd 0.103.0 (and over) are API compatible, this pc file declares the  
"jackd" 0.103.3 version number.  JackOSX is now 0.76.

Stephane
-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: autoconnect on OS X with old jack?

Jonatan Liljedahl
Stéphane Letz wrote:

> Le 19 mars 08 à 01:34, Jonatan Liljedahl a écrit :
>
>> The Jack OSX framework is still 0.101.1... will there be a new release
>> soon?
>>
>
> The situation on OSX is the following : starting with JackOSX 0.75
> package, jackdmp is used installed of old jackd. Jackdmp is compiled as
> 2 frameworks, but the libjack.so and libjack.so.0 links are done so that
> applications coming from Linux can still be compiled and linked without
> complaining. Moreover a jack.pc file to be used by pkg-config is
> installed in /usr/local/lib. Because jackdmp (0.69 and over) and jackd
> 0.103.0 (and over) are API compatible, this pc file declares the "jackd"
> 0.103.3 version number.  JackOSX is now 0.76.

I see! So it should be possible to simply use pkg-config and everything
should "just work"? If one wants to link to the native framework, which
one would I link to?

--
/Jonatan         [ http://kymatica.com ]

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel
Reply | Threaded
Open this post in threaded view
|

Re: autoconnect on OS X with old jack?

Stéphane Letz

Le 19 mars 08 à 13:34, Jonatan Liljedahl a écrit :

> Stéphane Letz wrote:
>> Le 19 mars 08 à 01:34, Jonatan Liljedahl a écrit :
>>
>>> The Jack OSX framework is still 0.101.1... will there be a new  
>>> release
>>> soon?
>>>
>>
>> The situation on OSX is the following : starting with JackOSX 0.75
>> package, jackdmp is used installed of old jackd. Jackdmp is  
>> compiled as
>> 2 frameworks, but the libjack.so and libjack.so.0 links are done so  
>> that
>> applications coming from Linux can still be compiled and linked  
>> without
>> complaining. Moreover a jack.pc file to be used by pkg-config is
>> installed in /usr/local/lib. Because jackdmp (0.69 and over) and  
>> jackd
>> 0.103.0 (and over) are API compatible, this pc file declares the  
>> "jackd"
>> 0.103.3 version number.  JackOSX is now 0.76.
>
> I see! So it should be possible to simply use pkg-config and  
> everything
> should "just work"? If one wants to link to the native framework,  
> which
> one would I link to?
>
> --

pkg-config  will see -ljack that actually is a link to Jackmp.framework

Stephane
-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel