qJACKctl not working

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

qJACKctl not working

Mich-C
Hi guys I'm using MX Linux 17.1 on my laptop
----------
Audio:
  Card-1: AMD Kaveri HDMI/DP Audio driver: snd_hda_intel
  Card-2: AMD FCH Azalia driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-1-amd64
---------

I want to use Guitarix and Jack to play my guitar on Linux.
I have an "interface" of this type (https://www.newfrog.com/product/3-meters-usb-guitar-cable-guitar-bass-1-4-6.3mm-to-usb-interface-connection-pc-instrument-cable-audio-adapter-converter-cable-146307) that works perfectly on Windows with Asio drivers.
As soon as I installed Jack, I managed to start it and in guitarix the audio was detected when I was playing ... the problem is that I could not get output audio ...
So I thought about compiling and installing the jack2 source hoping that it will work, but the situation only got worse, there must have been some conflict that I did not solve even by reinstalling the normal jack package several times.
Now when I start Jack I get this "Error - I can not start Jack- sorry" and in the messages tab I always get this report:
-------------
"Cannot connect to server socket err = File o directory not exist
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
14:03:37.548 Change in the ALSA connections graph"
---------------
I also tryed other combinations and the error it's the same
Please can you help me?
Many thanks in advance