us122 woes

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

us122 woes

Julian Squires

Hi, jackit-devel.

I'm having some problems with my Tascam US-122 and jack, on a powerpc
mac mini.  When I run jackd with -S, everything works fine, and I have
been using ardour and so on quite happily with that mode.  When I try
using 32-bit mode, I get extremely loud noise (constantly clipping)
from the capture ports, no matter what's going on.

Curiously, when I use jackrec with -b 24, it seems to record fine[1],
but when I use -b 32, it produces intermittent (but rapid) noise[2].
(jackrec -f foo.wav -d 1 -b {24,32} system:capture_1 system:capture_2
for both of those files; beware, the second one is obviously very
loud.)

Originally I thought this was a byte swapping issue, but I've verified
that quirk_bswap is being set to one, which appears to be the correct
behavior here -- I've also tried hard coding it to zero, which seems
to behave similarly.

Here's the output of jackd running when I captured those two samples:
(it's the current svn of jack, with a jack_error added to emit the
value of quirk_bswap for my own verification)

julian@onion:~/jack% ./jackd/jackd -R -d alsa -d hw:1 -r 44100 -p 4096 -n 2 -H -M
jackd 0.107.4
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:1|hw:1|4096|2|44100|0|0|hwmon|hwmeter|-|32bit
control device hw:1
configuring for 44100Hz, period = 4096 frames, buffer = 2 periods
quirk_bswap : 1
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 2 periods for capture
quirk_bswap : 1
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 2 periods for playback


I'm using this machine only for studio recording, no realtime
performance or monitoring, so latency doesn't matter at all to me, so
normally I use a period of 4096 frames.  I've tried with a variety of
other settings, though, to no apparent improvement.  I'm pretty sure
-r 48000 behaves the same, too.

I've also tried using the rawusb mode instead; originally I was going
to write that the behavior is basically the same, but when I just
tried it then, I got:

jackd watchdog: timeout - killing jackd
zsh: abort (core dumped)  ./jackd/jackd -R -d alsa -d hw:1,2 -r 44100 -p 4096 -n 2 -H -M

when I tried to record the 24-bit sample.  (the 32-bit sample is much
like in generic mode, see [3])  Stupidly, I deleted the core file
habitually, and then when I tried it again, it didn't do it again.
But the 24-bit file, this time, is bursts of noise punctuated with
silence.[4]


I'm happy to try and fix the problem myself, but I'm hoping someone
out there might have some ideas of what I can try next.  I spent a
little while reading the jack source, but I haven't yet had the time
to invest to figure out what jackrec -d 24 is doing differently, and
more importantly, whether I could switch ardour into a similar mode.

I don't think this has any relation with the US-122 problems
reported by Matt Savigear earlier, but it's possible.

Cheers.

Samples:
[1]  http://cipht.net/tmp/jack/jack32-jackrec24.wav
[2]  http://cipht.net/tmp/jack/jack32-jackrec32.wav
[3]  http://cipht.net/tmp/jack/jack32raw-jackrec32.wav
[4]  http://cipht.net/tmp/jack/jack32raw-jackrec24.wav

--
Julian Squires

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Jackit-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jackit-devel